Back to overview
Resolved

Freed is unavailable

Aug 3, 2026 at 3:00pm UTC
Affected services
Application site
API services
Visit processing

Resolved
Aug 3, 2026 at 3:32pm UTC

Our site has recovered to normal operations at this time.

Created
Aug 3, 2026 at 3:00pm UTC

Our site is currently experiencing issues and unable to load right now. Our engineering team is currently investigating the issue.