Freed website is not loading or is very slow to load
Resolved
Apr 13, 2026 at 8:52pm UTC
The site is now recovered and visits affected during the outage have been successfully re-processed.
Affected services
Updated
Apr 13, 2026 at 5:21pm UTC
We have applied an update and are seeing services recovering. The site is functional, visits are recording successfully, and engineering is currently re-processing all the notes affected by the outage.
Affected services
Created
Apr 13, 2026 at 4:25pm UTC
Freed is currently running into issues where the site is not loading or is slow to load and visit generation is not succeeding. Our engineering team is investigating the issue.
Affected services